MPASM and MPLABX

Discuss the Integrated Development Environment (IDE)

Moderators: David Barker, Jerry Messina

Post Reply
Jerry Messina
Swordfish Developer
Posts: 1140
Joined: Fri Jan 30, 2009 6:27 pm
Location: US

MPASM and MPLABX

Post by Jerry Messina » Sat May 23, 2020 10:49 am

I just thought I should warn anyone that likes to keep MPLABX up to date...

The recent MPLABX 5.40 update dropped support for the mpasmx assembler that's required for Swordfish and all the utilities.
The last version of MPLABX that includes mpasmx 5.87 is MPLABX 5.35, so if you update be sure to keep a copy of 5.35.

The SF MPLABX plugin works with 5.40 but for the time being you will be limited to devices supported by 5.35.

W4GNS
Registered User
Registered User
Posts: 19
Joined: Wed Nov 03, 2010 7:18 pm
Location: Occupied South (Virginia)

Re: MPASM and MPLABX

Post by W4GNS » Sat May 23, 2020 12:17 pm

Gary W4GNS

Jerry Messina
Swordfish Developer
Posts: 1140
Joined: Fri Jan 30, 2009 6:27 pm
Location: US

Re: MPASM and MPLABX

Post by Jerry Messina » Sat May 23, 2020 3:48 pm

Thanks Gary.

I should add... you really only need the mplabx/mpasmx files from 5.35 if you're trying to create your own device libraries.
Otherwise, everything you need is included with the compiler.

The version of mpasmx included with SF has a modified database file to fix some issues with the standard version from mplabx.

Post Reply