Search found 26 matches

by RDHeiliger
Sat Feb 06, 2010 5:42 am
Forum: Compiler
Topic: PIC18F14K50 and USB
Replies: 11
Views: 12868

14K50 MPASM 5.33 Required

Just downloaded the latest update to the Swordfish compiler binary.

It replace my MPASM v5.33 with MPASM v5.11
v5.11 does not support the PIC18F14K50 parts.
results in hundreds of error messages.

Thought some might want to know this????

RD
by RDHeiliger
Sun Sep 13, 2009 8:43 pm
Forum: Compiler
Topic: Swordfish update has old MPASMWin.exe
Replies: 0
Views: 2485

Swordfish update has old MPASMWin.exe

The MPASMWin.exe file included with the update I installed last night will not assemble code for the 14K50. I use the MPASMWin.exe file dated 8/7/2009. Believe it is v5.33.

RD
by RDHeiliger
Wed Aug 12, 2009 3:48 am
Forum: Compiler
Topic: PIC18F14K50 and USB
Replies: 11
Views: 12868

Your right.

I had MPLAB v8.1 in another directory, copied the MPASM file from there to the Swordfish Bin folder and the program compiled. Now i just need to make the board and see if it works.

Thanks!!!!!!!!!!!!!!

RD
by RDHeiliger
Tue Aug 11, 2009 3:29 pm
Forum: Compiler
Topic: PIC18F14K50 and USB
Replies: 11
Views: 12868

Not sure if you are replying to me or to the first gentleman. The program i am trying only has the USART, and Analog modules in it, no USB. It simply reads analog inputs and sends them out serially. Here is the code. Device = 18F14K50 Clock = 16 Config FOSC = IRC // uses USART and AD libraries... In...
by RDHeiliger
Mon Aug 10, 2009 3:22 pm
Forum: Compiler
Topic: PIC18F14K50 and USB
Replies: 11
Views: 12868

I have had a couple of 14K50's for awhile, finally came up with a project. I am getting assembler errors (Illeagle Opcode). The program assembles fine when i use a 46K20 as the chip, I get the errors when i use the 13K50 or 14K50. This is a bit of the listing file where the errors start. Any thought...
by RDHeiliger
Fri May 01, 2009 3:01 am
Forum: User Modules
Topic: 18F26K20 SD Testing
Replies: 55
Views: 27264

I have put together another board with just 10K pullups on the DO and DI lines that works just fine. I also used just a single 1 amp 3.3 volt regulator with a 10uF electrolytic after to stabilize. The spec of 60 mA on read and write to the microSD card was a bit surprising and the major culprit in n...
by RDHeiliger
Sat Apr 25, 2009 5:10 pm
Forum: User Modules
Topic: 18F26K20 SD Testing
Replies: 55
Views: 27264

SDFileSystem Benchmark for 18F46K20

Results of above benchmark test. All tests done with internal oscilator. PLL used to get 32 and 64 MHz PIC18F46K20-I/P Failed to format card at 64 MHz and div 4 passed at 64MHz and div 16. Device = 18F46K20 Clock = 8 Config FOSC = INTIO67, WDTEN = OFF, BOREN = OFF #option SD_SPI = MSSP #option SD_SP...
by RDHeiliger
Sat Apr 25, 2009 4:53 am
Forum: User Modules
Topic: 18F26K20 SD Testing
Replies: 55
Views: 27264

46K20 Internal oscilator

I have the SDFileSystem running on a 18F46K20 with internal oscilator at 64 MHZ using either MSSP or SW. 47K pullups on DO and DI. The main problem i ran into is that I was trying to use a 78L33 regulator to run my entire board. I noticed that inserting the card would reset the processor even tho I ...
by RDHeiliger
Sat Apr 25, 2009 1:44 am
Forum: User Modules
Topic: 18F26K20 SD Testing
Replies: 55
Views: 27264

Looking at the electrical specs for K20's data sheet there are two charts on VDD vs Max Frequency. Standard chip @ 1.8 - 3.0v max freq is 20MHZ Standard chip @ 3.0 - 3.6v max freq is 48MHZ Military chip @ 3.0 - 3.6v max freq is 64MHZ May have some thing to do with not being able to init the SD card ...
by RDHeiliger
Sun Mar 22, 2009 5:00 am
Forum: IDE
Topic: Conflicts between SFcompiler 2.1.0.1 and MPLAB IDE v8.10
Replies: 19
Views: 14209

I added the directory in the documents and settings and copied the includes and library there. This did allow a successfull build. I also had two moduals in the UserLibrary of my own that also needed to be move to the library directory in documents and settings. I was looking in MPLAB and there is a...
by RDHeiliger
Thu Mar 12, 2009 5:39 pm
Forum: Modules
Topic: Using USB with Sleep
Replies: 0
Views: 2041

Using USB with Sleep

I am attempting to use USB in a battery powered logger. The USB is not normally connected. USB is used only to upload data. I use Tmr1 with an external 32KHz Xtal for a 1 second time base for a Real Time Clock. The PIC18F2550 remains in SLEEP for the entire one second. On waking up on the Tmr1 inter...
by RDHeiliger
Sat Jan 31, 2009 12:13 am
Forum: Compiler
Topic: USB and SDFileSystem memory over alocation error
Replies: 10
Views: 4053

After poking around in the USBCDC modual, decided that the Public "BufferRAM" is not used internaly in the USB modual and is free to be used by user program. I returned to using the USBCDC modual without any modifications. I only changed the buffer address in the SDFileSystem to absolute adress $600...
by RDHeiliger
Fri Jan 30, 2009 6:14 pm
Forum: Compiler
Topic: USB and SDFileSystem memory over alocation error
Replies: 10
Views: 4053

I am not sure how the 512 byte buffer is used by USB when the "USB_EXTENDED_RAM" is set true. It says it is a public buffer. If it is not declared does not USB use the smaller TX and RX buffers already declared. Here is what I tried, with success in getting it compiled. Changed the USBConfig back to...
by RDHeiliger
Fri Jan 30, 2009 1:40 am
Forum: Compiler
Topic: USB and SDFileSystem memory over alocation error
Replies: 10
Views: 4053

realized i changed the structure instead of the alocation. did this: Structure TShared CurrentSectorBuffer($200) As Byte End Structure Dim Disk As TDisk Absolute $530 Dim File As TFile Absolute $570 Dim Shared As TShared Absolute $5F0 #if SD_SUPPORT_MULTIPLE_FILES = TRUE Dim StoredFiles(MaxFiles) As...
by RDHeiliger
Fri Jan 30, 2009 1:01 am
Forum: Compiler
Topic: USB and SDFileSystem memory over alocation error
Replies: 10
Views: 4053

I modified the USBConfig.bas to remove the 18F2550 from the choices. I modified the SDF file system as follows: Dim Disk As TDisk Absolute $550 Dim File As TFile Absolute $650 Still recieved the ram error. Noticed the TDisk and TFile structures are only about 40 bytes each tho. Removed that edit and...